ICode9

精准搜索请尝试: 精确搜索
首页 > 编程语言> 文章详细

1004 Counting Leaves Java

2021-02-23 09:58:22  阅读:214  来源: 互联网

标签:case 01 Java int Leaves new input 1004 ID


1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0

import java.util.*;

public class Main {
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        int totalNode=input.nextInt();
        int innerNode=input.nextInt();
        Map<Integer,List<Integer>> nodeMap=new HashMap<>();;
        for(int i=0;i<innerNode;i++){
            int No= input.nextInt();
            nodeMap.put(No,new ArrayList<>());
            int number= input.nextInt();
            for(int j=0;j<number;j++)
                nodeMap.get(No).add(input.nextInt());
        }

        List<Integer> number=new ArrayList<Integer>();
        List<Integer> queue=new ArrayList<Integer>();
        queue.add(1);

        int cnt=0;
        int last=1;
        while(queue.size()>0){
            int temp=queue.get(0);
            if(nodeMap.get(temp)==null) {
                cnt++;
            }else {
                for(int i=0;i<nodeMap.get(temp).size();i++){
                    queue.add(nodeMap.get(temp).get(i));
                }
            }
            if(temp==last){
                    last=queue.get(queue.size()-1);
                    number.add(cnt);
                    cnt=0;
            }
            queue.remove(0);
        }


        for(int i=0;i<number.size()-1;i++){
            System.out.print(number.get(i)+" ");
        }
        System.out.print(number.get(number.size()-1));
        }
        
}

标签:case,01,Java,int,Leaves,new,input,1004,ID
来源: https://blog.csdn.net/weixin_45549192/article/details/113972987

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有