ICode9

精准搜索请尝试: 精确搜索
首页 > 编程语言> 文章详细

2019中山大学程序设计竞赛 Enlarge it(水题)

2019-04-20 16:51:05  阅读:293  来源: 互联网

标签:水题 .. characters Enlarge 2019 Taotao each test include


Problem Description Taotao is glad to see that lots of students have registered for today's algorithm competition. Thus he wants to pull a banner on the wall. But Taotao is so stupid that he doesn't even know how to enlarge words to fit the size of banner. So Taotao gives you a slogan template and asked you to enlarge them in k times.  

 

Input There are multiple test cases.
For each test case, first line contains three numbers n, m, k (1<=n, m<=100,1<=k<=10).
The next n lines each contain m visible characters.  

 

Output For each test case, you should output k*n lines each contain k*m visible characters to represent the expanded slogan.  

 

Sample Input 3 3 2 .*. .*. .*.  

 

Sample Output ..**.. ..**.. ..**.. ..**.. ..**.. ..**..
#include <cstdio>
#include <iostream>
#include <vector>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
#define ll long long
const int inf = 0x3f3f3f3f;
const  ll linf  =1LL<<50;
const int maxn = 1e5+8;
const ll lmaxn = 2*1e9+8;
const ll mod = 1000000007;
int sign[10000+8];
char a[100+8][100+8];
int n, m, k;
int main()
{
    while(~scanf("%d%d%d", &n, &m, &k) && (n+m+k))
    {
        getchar();
        int cnt = 0;
        for(int i = 1; i<=n; i++)
        {
            for(int j = 1; j<=m; j++)
            {
                scanf("%c", &a[i][j]);
                if(j>1 && a[i][j] != a[i][j-1])
                {
                    sign[cnt++] = j-1;
//                    cout<<sign[cnt-1]<<endl;
                }
                if(j == m)
                {
                    sign[cnt++] = j;
//                    cout<<sign[cnt-1]<<endl;
                }
            }
            getchar();
        }
        int miao = 0, ying = 0;;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= m*k; j++)
            {
                printf("%c",a[i][sign[miao]]);
                if(j == sign[miao]*2)
                {
                    miao++;
                }
            }
            printf("\n");
            for(int j = 1; j <= m*k; j++)
            {
                printf("%c",a[i][sign[ying]]);
                if(j == sign[ying]*2)
                {
                    ying++;
                }
            }
            printf("\n");
        }
    }
    return 0;
}

 

标签:水题,..,characters,Enlarge,2019,Taotao,each,test,include
来源: https://www.cnblogs.com/RootVount/p/10741494.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有