ICode9

精准搜索请尝试: 精确搜索
首页 > 编程语言> 文章详细

1031 Hello World for U (20 分) java 题解

2021-10-02 20:01:49  阅读:203  来源: 互联网

标签:20 string int 题解 builder len characters java append


Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目大意:

给定一串字符串,使其按U字形输出。

解题思路:

按照题给公式计算出行数以及需要添加的空格数即可。

java代码:

import java.io.*;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String s = br.readLine();
		int len = s.length();
		int n = (len + 2) / 3 - 1;
		int space = len - 2 * (n + 1); 
		StringBuilder builder = new StringBuilder();
		for(int i = 0; i < n;i++) {
			builder.append(s.charAt(i));
			for(int j = 0; j < space;j++) {
				builder.append(" ");
			}
			builder.append(s.charAt(len - 1 - i) + "\n");
		}
		for(int i = n;i < n + space + 2;i++) {
			builder.append(s.charAt(i));
		}
		System.out.print(builder.toString());
	}
}

PAT提交截图:

标签:20,string,int,题解,builder,len,characters,java,append
来源: https://blog.csdn.net/weixin_48898946/article/details/120588373

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有